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Chapter 1

Getting Started

Introducing the DSE 890 (Drive System Explorer) Configuration Tool for the 890 drive.

Here are the instructions for installing DSE 890, connecting the drive to your PC, and finally
launching DSE 890.
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- Introduction

DSE 890 Installation

Connecting to the Drive

Launching DSE 890
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Introduction

DSE 890 (Drive System Explorer) is the software tool for the new 890 range of drives available from SSD
Drives. It can parameterise, configure and program both the 890CD Common Bus Drive and the §90SD

Standalone Drive.

Using straight forward block programming you can very quickly become a confident user of DSE 890.
Users of LINK and DSD (Drive System Designer), our two previous products, will appreciate DSE 890's

similarity with DSD and familiar features.

However, DSE 890 is new. A major concept is that of having three environments: Motor Control,

Application, and the I/O Elements:

Motor Control: this is a fixed environment comprising
drive and motor parameters organised into blocks. You can
parameterise these blocks, or you can read and write to
them by linking their parameters with blocks in the
Application environment.

Application: this is the working space, external of the
Motor Control environment. In it you can place any
number of instances of any block - gone are the days of
fixed numbers of blocks.

I/0 Elements: this is an environment where all the drive's
I/O 1s gathered. However you do see this I/O bought out in
the relevant blocks in the Application environment.
Outputs are fixed and Inputs are instantiated.

DSE890

I/O

890 configuration/application

Block

/o

Biock Motor
Control

A

Application

Control
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DSE 890 Installation

DSE 890 is supplied on a CD with the 890 Drive. You can install DSE 890 on any PC with the following
specification:

¢ Windows XP, Home or Professional Edition
¢ 100MbD of free hard disk space

Insert the CD and execute the "set up. exe" file on the disk to install the latest LINK database and DSE
890. Follow the on-screen instructions.

The DSE installation program "set up. exe" will copy the Texas USB driver files into the appropriate
Windows directories. When the 890 drive is connected for the first time, Windows will acknowledge that it
has found new hardware with the "New Hardware Found" wizard. When prompted for a driver, select the
"Install automatically" option and select "OK".

Note Windows will actually prompt with ""New Hardware Found" twice.
This is the expected behaviour of Windows.

Connecting to the Drive

Connect to the 890 Drive using a proprietary USB lead: A to mini-B. Connect the PC's USB port to the
drive's X10 terminal. For a drive system, you can connect via USB to any drive in the system to gain access
to all drives. All drives in the system must be linked via the FireWire Option.

For more information on the FireWire Option please refer to the FireWire Option Technical Manual.
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Launching DSE 890

Start DSE 890 by clicking its program icon in Windows. Or, in the Windows' Start Menu click on "All
Programs", you will see "SSD Drives", and within is the configuration tool. Click on this to launch DSE

Page 1-4

890.

25E DSE 890
E::-{'.Eﬂé Edit View E,l’@jécf- Command  Window Help

Parameters

{none)

Displays the Properties View
Document Settings
Global Settings
B Version
Appiersion
Form Yersion
Language English

Connected at 230400

‘Scratch Pad o ox
Tue Apr 04 14:34:40 2006 A
User name is ‘AN, Other' =
Lite mode
connected to 'L890_1' {890 v2.2) - OK, CPU 5.1%, Heap: 13.7%, 0 msgs/s =

g
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Selecting the Comms Port

When DSE 890 is first launched you will see the Properties box. From the Properties box, open "Global
Settings" and select "Serial Comms Port". Now select the port your drive is connected to. If you have
selected correctly, the Serial Comms Port description will read "USB-Serial Port". Now you can close the
DSE 890 Properties dialog.

Properties
~
=

User Mame A N Other

Database path CASEDLIMKY,

Serial Comms Port COME j
Access Module List at Start Up Trie

Mumber of revisions kept 10

Mumber of recent projects listed 2

Mo Module List Update False

Save Source True

Edit at Online True %

Serial Comms Port
LISE - Serial Fort

What To Do Next

At this point you will have a drive connected to your PC, DSE 890 launched and the comms port
configured. Now you are ready to go to the next stages:

¢ creating your first configuration (page 2-2), or alternatively
¢ opening the pre-installed default configuration on-line (page 2-8).

Both possibilities are described in the next section.
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Chapter 2

First Configuration

How to create, modify and install a new configuration as well as going online.

Creating a Configuration

Modifying a Configuration

Import/Export a Configuration

' LéSEeso

L4
¢
¢ Installing a Configuration
L4
¢

The Online Configuration
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First Configuration

Creating a Configuration

1. From the "File" menu, select "New". A Dialog will
pop up. Select a configuration, e.g. 890 Volts/Hertz,
and click "OK".

New Configuration [Z|

290 Active Front End Ol
290 Closed Loop Vector (Default)

290 Permanent Magnet AC il

290 Sensorless Yector (Defallt)
290 Shaftess Printing
290 Volts/MHertz (Defallt)

290 Regen mode, Regenerative Active Front End.

. User Input R|
2. When prompted, enter a new configuration name, —
e.g. "L890 1", and click "OK". Enter configuration name:

3. And here is your first configuration L§890 1*. | ok | | cancel |

Save the configuration by clicking on File/Save or the Save icon, or select "Save" from the "File" menu.
A standard Windows Save dialog will pop up. You can save the configuration in any directory in your
file system. Once saved, the asterisk "*" against the name will disappear.
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Modifying a Configuration

A configuration can be modified by editing blocks and links, inserting or deleting blocks.

225 DSE 890 - [L890_1*]

- OX

! Fle Edt  iew Project Block Command [nsert Format  Window Help -8 X
ZH A BEEEEEE =2EE0)
Parameters - LBO0_1  # x [arprvasys apx
g 2,
1 o
- sz
:EEEn il e A= “.;: | r“:mmTT nn —° _®spssn
TRHRFAT il . 1 L. e i _— 7
— e
2 +10% %18
= 1 RUMMING
2| -ov B o PLE
s _l1a ZERQ SPEED
x‘15 Lhaki S ———
Joc P | r
1 T ﬂ
ETART 1 1 Leal.d
— [ &3 =l
=ToR _— Lk = i wewr :
M4 1of1 oM - v ‘ + < >
Scratch Pad T x
loading 'CASSD_LINKMONFIGSWEYASI0WHZDF 004 ~
daone. B
loading 'CASSD_LINKMONFIGSWEYASI0WHZDF 004
= daone.
Quick Setup =
W
Ready Connected at 230400
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Editing Blocks

You can view the contents of any function block in the
configuration by double-clicking the icon for the block. EsERLERELEELTAUARELEILT Nl 8]
For example, double click on "AN IN 3" will open the
analog input function block 3.

100
Offset 0
Sample rate {ms) 100 ms

Where a parameter can be edited, click on the relevant
sub-menu [ to display the options (for enumerated and
boolean parameters), or edit the displayed numeric
value directly on the screen by clicking on the value.

When you have finished editing the block select "OK"
to exit the block, otherwise select "Cancel" to exit the gcal'e
block and disregard any changes you may have made. e

When you make any changes, save the configuration by ok | | cancel
clicking on the Save icon M, or "File->Save". This will
remove the asterisk ( * ) against the configuration name.

Editing Links

AN N 2 Motor Control AN OUT 1

A link transfers the value of  "™@9%%lscae xiz.04 0.00 % g atdp INFUT SPEED % 12-06
0.00% .00 % 100.00%

an output parameter to an T 20 e calsline ARG oovklarrser

. £ h AN IH 4 E::zz E;EE_T ZER'_‘C'EiiEEg AH OUT 2
mput parameter of another 100005 (oca e xizos False | o naE B
D% nrrsET D0% e E

(or the same) block. o ooow|SEetE
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Links are made by connecting an output to an input, in that order.

Hover the cursor over the output line until an "x" appears. At this point, click
and hold the mouse button. Now stretch the red link to the input line. When the
link turns green, you have a possible connection. To make the connection, let go
of the mouse button.

To make a link

To delete a link Click on the line. It will turn purple. Press the Delete key on your keyboard.

Click on the line and hold the mouse button. The line will turn purple. Now you

To reshape a link line can drag any part of the line in any direction.

Inserting New Function Blocks

You can insert any number of new function blocks into the Application. For example:
Click on the Block menu at the top of the screen.
1. Move the cursor down to select "Logic" and select "Counter".

2. Click to attach the block icon to the cursor. Move the icon to where you want on the screen. Click again
to release the icon.

3. To insert another of these blocks you can repeat the process, or just Copy and Paste the original using
the Edit menu at the top of the page. (The standard Ctrl+C, Ctrl+V and Ctrl+X also apply).

Note For further details of all function blocks, refer to the 890 Engineering Reference manual, Appendix D.
Motor Control Block details are available in DSE 890 by right-clicking a function block in the Motor
Control Block pane and selecting "Help"'.

Deleting Function Blocks

Select a block and hit the "Delete" key. This will delete the block.
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Editing the Motor Control Block

Double-click the Motor Control Block. A new window will display the motor control block diagram.

£5% DSE 890 - [LB90_1-Motor Control]

! Fle Edt  Wiew Project Block Command  Insert Format  Window Help - g X
ZEEd QA FEEH BEEE = EE!
Parameters _LE890_1 al | 1850_1* 7 '1890_1-Motor Control | b x
= ~ P
ACCESS COMNI REFERENCE
ANIN 3 REFERENCE RAMF
AN N 4 SKIP FREQUENCIES RAMPING — L
AW OUT 1 QuTPUT L'”ﬁ’;‘i— RAMP TYPE -
AN OUT 2 % WPUT Haf 105 DECEL TIME B
DIG M 1 RAMP INFUT S iNpuT - Fale SYMMETRIC MODE -
ZIBAND 1 - SSYMMETRIC TIME |-
DIGIM 2 g :z— FREQUENCY 1 - 1;';;— SR&MP CONTINUOUS |-
2 BAND 2 - 2| SRaMP ACCEL -
DIGIN 3 DRz rpEQuENCY 2 - 1852 cRamP DECEL -
DIG M 4 UHZ g anD 3 - 18/52) SRamP JERK 1 -
DRzl rpEQUENCY 3 - 10453 cp P JERK 2 -
DIG OUT 1 g :z— BAND & - 13 ;53— SRAMP JERK 3 -
DIG GUT 2 2 FREQUENCY 4 - Foe] ﬁgﬁr{;ﬂp JERK 4 -
DI QUT 3 REFERENCE
REFERENCE JOG
1O COMFIGLUR SPEED DEMAND LU PR—
C SPEED SETPOINT 15 ACCEL TIME
ALITO REST LoCAL SETPOINT ! 2|oEcEL TIME =4
AUTOTUNE Mo 1of4 L = 10025 w | |2 >
COMMS O
CURRENT L SE;atch EI;’ad 3 x
ite mode A
DYNAMIC B connectad to 'L890_1' (890 ¥2.2) - OK, CPU 5.1%, Heap: 13.7%, 0 msgs/s
EMC CAPAC v | loading 'CASSD_LINK\CONFIGS\WEWASS0VHZDF 004"
= dane.
Motor Control
W
Ready Connected at 230400 [ |
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Connecting Parameters to the Application

If a motor control block has to be written to or read from the application, Inputs and Outputs can be added

to the Motor Control block diagram, respectively.

For example, to add a new input parameter called "REVERSE",
open the Motor Control Block diagram, add a new input from the
Block menu, then rename it to "REVERSE" (shown connected to
REFERENCE /REMOTE REVERSE).

COMMS SETPOINT 1S00RFM |

On exiting, the motor Control Macro the additional input parameter
"SETPOINT" will automatically appear on the Motor Control block as
shown on the right.

DSE 890 Configuration Tool - QuickStart

REFERENCE

REFEREHNCE

RAMF INPUT g:
TRIM INFUT T

-110% |
Falze |
False

REYERSE
0%

SFEED DEMAND
SFEED SETFOINT
REVERSE
LOCAL SETROINT
LOCAL REVERSE
FIIRE SETPOINT
SFEED DEMAND
REMOTE SETFOIMT
SFEED TRIM
hAx SPEED CLAMP
MIN SFEED CLAMP
TRIM IN LOCAL
REMOTE REWERSE

COMMS SETFOINT
hAx SPEED

Motor Cortrol

0% | o AMP INPUT
0% | TR INPUT
Falze 106
False lqrapT
Falze sTOF
False | pEvERSE
— COMMS SETFOINT

SFEED
TORQUE
RUNMING
ZERO SFEED
HEALTHY

|
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Installing a Configuration

Once you have created your own configuration, you are in a position to install it in the drive. Select
"Command->Install At Selected" to install the currently opened configuration into a drive.

The installation will be confirmed by a Scratch Pad - 00000890:Public /Standalone
Scratch Pad message.

current serial number: 0448-Uk-E-0020

SR . Beginning download to; Link3 Module (MTID 2818)
Now the configuration is installed into REEEIE TS TR . 8 I,

your drive.

Autotune

Now perform an Autotune. The configuration must be closed:

1. Trigger Autotune in the drive (via the MMI) and wait for it to be completed.

2. Select File->Update; this will update the parameters in DSE's copy of the configuration.
This will ensure that your DSE 890 configuration reflects exactly the state of the drive.

The Online Configuration
Opening the Default Configuration Online

If you did not install a configuration in the drive, select " File=>Open Online " or simply hit "F9" to open
the default, shipping configuration in online mode.

Opening a New Configuration Online

At this point, your configuration should be installed in the drive. Now, select "Command->Go Online" and
the configuration will be opened in online mode. Alternatively, you can select "File=>Open Online", or
simply hit "F9".
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Working Online

The ONLINE configuration window looks the same as an OFFLINE S CaX
version, but has some extra features. Note that you cannot remove or = m—
. . . AN
add blocks and links in online mode. L Fep——
. OFFSET
When you hover the cursor over the output of a block, the cursor will 100 ms

change to the shape of a "cross". Shift-click puts the parameter into
the monitor list. To read the value in the function block and the
scratchpad, just click. DSE 890 will get and display the actual value from the drive.

1of1

The Scratch pad will become visible and will display the retrieved value. The same happens if you click on
an input of a block while holding the "SHIFT" key.

If you want to change an input value of a function
block, simply click on the block input while holding
down the "CTRL" key. This will bring up a dialog Enter Scale:
prompting for the value to be set. For instance, clicking :
on AN IN 3 : SCALE while holding the CTRL key will
open the following dialog. ok | | cancel

User Input

X
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Install New Firmware

In the Command Menu, select "Install Firmware". A dialog will pop up which allows you to select a
firmware:

Install Firmware

Select Firmware: 890 Drive (version 1.4 firmware

Instal | ‘ Cancel |

Once selected, press OK and the firmware download will start. It may take a few minutes.
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